redmine-a1-theme v1.0.0

Zdecydowałem się upublicznić forka tematu A1, który wykorzystuję w mojej prywatnej instalacji Redmine do zarządzania projektami. Jest to fork oryginalnego tematu A1 od RedmineUP, który dostosowałem odrobinę do swoich potrzeb oraz poprawiłem kompatybilność z Redmine 3.3 (oryginalny temat wydaje się nierozwijany od dłuższego czasu i nie wspiera nowych wydań Redmine).

Temat można pobrać z GitHuba. Aby go zainstalować wystarczy wypakować katalog z tematem do public/themes/ (docelowa ścieżka ścieżka do stylów powinna wyglądać tak: public/themes/a1/stylesheets/application.css) oraz włączyć styl w panelu admina Redmine. Temat jest kompatybilny z Redmine 3.3 (powinien działać też ze wcześniejszymi wersjami, ale nie testowałem go po tym kątem).

Wyłączenie Gramstatów

Wyłączenie Gramstatów

Minęły już prawie 2 lata od kiedy Gramstaty zostały zamrożone i nie aktualizują statystyk. Od tamtego czasu na stronę trafiają tylko boty i zbłąkane dusze, które kliknęły zły link w wynikach wyszukiwarki Google. W tym momencie nie widzę większego sensu w hostowaniu tego projektu – z dniem dzisiejszym statystyki zostają całkowicie wyłączone. Z tego co wiem nowe forum Gram.pl nie udostępnia żadnych statystyk, nie ma więc żadnej znanej mi alternatywy. Ale sądząc po ruchu na stronie, nikt jej nie potrzebuje :).

yii-tinymce v1.0.1

Rozszerzenie yii-tinymce zostało zaktualizowane. Zmiany to:

  • jQuery nie jest już wykorzystywane przy inicjalizacji edytora.
  • Jeśli tryb debug jest włączony, wykorzystywana jest nieskompresowana wersja tinymce.

Kod rozszerzenia można pobrać z repozytorium na GitHubie lub zainstalować za pomocą Composera.

yii-tinymce – edytor WYSIWYG dla Yii

Wydałem nowe rozszerzenie do Yii 1.1: yii-tinymce. Jest to prosty widget integrujący edytor TinyMCE z Yii 1.1 z możliwością podpięcia managera plików (np za pomocą rozszerzenia yii-elfinder2). Rozszerzenie bazuje na yii-tinymce ze znacznie uproszczonym kodem, integracją z Composerem oraz dostosowaniem konfiguracji do nowych wydań TinyMCE.

Wersję 1.0.0 można pobrać z GitHuba lub zainstalować za pomocą Composera.